Microsoft Service Outage – Email & MFA Delays

Incident Report for Arrowhead Programs

Resolved

Emails are starting to get sent through
Posted Jan 22, 2026 - 15:08 PST

Investigating

Microsoft is currently experiencing a service issue that is causing delays in email delivery and delayed or missing multi-factor authentication (MFA) prompts. This is due to errors on Microsoft’s servers and is impacting multiple organizations, not just ours.
During this time, you may notice:
Emails arriving later than expected
MFA push notifications, texts, or codes taking longer to arrive (or needing to be retried)
Microsoft is actively working to resolve the issue. No action is required on your part at this time. If an MFA prompt doesn’t arrive right away, please wait a moment and try again.
We’ll share updates as Microsoft provides them. Thank you for your patience.
Posted Jan 22, 2026 - 11:56 PST
This incident affected: Office 365 (Outlook).