Teams Voice - Degraded Performance

Incident Report for Arrowhead Programs

Resolved

Microsoft has resolved this issue
Posted Jul 27, 2026 - 13:24 PDT

Investigating

Microsoft Teams is working on a reported issue affecting main number greetings that allow a caller to dial by voice, including using the dial by name directory. Affected numbers may be silent instead of playing a greeting for callers.

If you're noticing issues with your main number, please report it to support@arrowheadprograms.com and we can implement a temporary solution. Please include your main number in the request.
Posted Jul 24, 2026 - 10:20 PDT
This incident affected: Office 365 (Teams).