Claims XPress & ACM Reports - Error Validating Report Trees

Incident Report for Arrowhead Programs

Resolved

This error has been resolved, if you continue to have any issues please notify the help desk at support@arrowheadprograms.com.
Posted Mar 25, 2025 - 08:20 PDT

Investigating

We are currently investigating this error within Claims Xpress and ACM Reports. We will update you as soon as we have a resolution.
Posted Mar 25, 2025 - 06:34 PDT
This incident affected: Apps and Services (Claims XPress).