Teams showing Odd Information

Incident Report for Arrowhead Programs

Resolved

You may notice new orgs being added in Microsoft Teams over the next few weeks.
This is part of the Accession integration, to help us better collaborate with our new teammates until they're fully migrated into our environment.
If you prefer not to see this information, you can toggle off the orgs under your Teams Settings > Accounts and Orgs.
Posted Oct 13, 2025 - 10:16 PDT

Investigating

We are aware of the issue where your teams profile is showing
safeware.com
van Wagenen
Waypoint Underwriting

We are investigating why this is occurring.
Posted Oct 13, 2025 - 07:10 PDT
This incident affected: Office 365 (Teams).