AWS Outage - Impacting Multiple Systems

Incident Report for Arrowhead Programs

Resolved

The AWS issue was resolved this morning, if you experience any ongoing issues please reach out to the help desk.
Posted Oct 21, 2025 - 08:25 PDT

Update

AWS has identified the root cause of the network connectivity issues and implemented multiple mitigations. They are actively working to restore full service and will share further updates as soon as possible. You can follow the progress here: https://health.aws.amazon.com/health/status?ts=20251020

Services that we are seeing an active impact on:
- Smartsheets
- JIRA
- Wiki
Posted Oct 20, 2025 - 09:21 PDT

Update

an AWS outage is causing intermittent issues with multiple systems, such as Jira and Smartsheet, but there are likely others being impacted, as well. We will continue to monitor and update you on the status.
Posted Oct 20, 2025 - 06:51 PDT

Monitoring

Atlassian is reporting system issues that are causing intermittent 503 errors, we will let you know once they have reported a resolution.

For more information you can reference https://status.atlassian.com/
Posted Oct 20, 2025 - 06:37 PDT
This incident affected: Apps and Services (Arrowhead Wiki, Jira, Smartsheet).