Workday Down

Incident Report for Arrowhead Programs

Resolved

This incident has been resolved.
Posted May 05, 2026 - 13:45 PDT

Investigating

A global issue is currently impacting Workday functionality. Please record any punch in/out times for subsequent submission to ensure accurate correction of your time cards.
Posted May 04, 2026 - 13:42 PDT
This incident affected: Apps and Services (Workday).