Some Teammates unable to access Microsoft Office Software

Incident Report for Arrowhead Programs

Update

Currently a small amount of teammates are experiencing an issue where they are unable to sign into Teams, Outlook, Onedrive, etc on their physical laptops.
We are continuing to work with Microsoft to find the root cause of this issue to resolve it.

If you begin to experience these issues, please email or call the help desk.
Support@arrowheadprograms.com
760-710-6840
Posted Dec 08, 2025 - 09:47 PST

Investigating

Currently a small amount of teammates are experiencing an issue where they are unable to sign into Teams, Outlook, Onedrive, etc on their physical laptops.
We are working with Microsoft to find the root cause of this issue to resolve it.

If you begin to experience these issues, please email or call the help desk.
Support@arrowheadprograms.com
760-710-6840

Thank you.
Posted Dec 03, 2025 - 07:49 PST
This incident affects: Office 365 (Teams, Outlook, One Drive).