The team continues to monitor progress and new tickets and issues have slowed down being reported.
If you are still being impacted by the issues from this week, please contact the help desk at support@arrowheadprograms.com for assistance or call 877-233-1455.
We're continuing to work on resolving the service disruption impacting some Microsoft 365 services. Many users have seen service restoration, but intermittent issues may still occur.
If you're currently experiencing issues, please contact the help desk at support@arrowheadprograms.com for assistance or call 877-233-1455.
Posted Mar 12, 2026 - 16:15 PDT
Identified
The team has applied a fix to all impacted computers. If you are still having issues please reboot and follow any instructions that appear after logging in. Your computer may ask you to sign in several times.
Posted Mar 10, 2026 - 17:28 PDT
Update
We are continuing investigating an issue that is impacting access for some users who are experiencing problems signing in or accessing certain Microsoft applications.
If you can log in to your laptop but cannot access Microsoft apps (Outlook, Teams, etc.): Please use the web versions as a temporary workaround (for example, https://outlook.com), it may require a private browser window.
If you are unable to log in to your laptop: Please try restarting your computer. In some cases, this may resolve the issue.
Our team is actively working to identify the root cause and implement a permanent fix. If the restart does not resolve the issue, please hang tight, we will send another update as soon as we have more information or additional steps.
Thank you for your patience
Posted Mar 10, 2026 - 15:06 PDT
Update
We are currently investigating an issue that is impacting access for some users who are experiencing problems signing in or accessing certain Microsoft applications.
If you can log in to your laptop but cannot access Microsoft apps (Outlook, Teams, etc.): Please use the web versions as a temporary workaround (for example, https://outlook.com), it may require a private browser window.
If you are unable to log in to your laptop: Please try restarting your computer. In some cases, this may resolve the issue.
Our team is actively working to identify the root cause and implement a permanent fix. If the restart does not resolve the issue, please hang tight, we will send another update as soon as we have more information or additional steps.
Thank you for your patience
Posted Mar 10, 2026 - 11:27 PDT
Update
We are continuing to investigate this issue.
Posted Mar 10, 2026 - 08:39 PDT
Investigating
We are aware of the issues with logging into Office applications or computer. We are actively investigating it and will provide an update as soon as we have the root cause.
Posted Mar 10, 2026 - 08:20 PDT
This incident affects: Office 365 (Teams, Outlook, One Drive, SharePoint) and Apps and Services (CloudPC).